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NOTE: This release contains updated software for HPE Shadowbase Enterprise 

Manager, a Microsoft Windows based application for controlling and 

monitoring Shadowbase replication environments. 

 

NOTE: This softdoc applies to the HPE Shadowbase Enterprise Manager 

component of T1122H06. Other softdocs document the releases of the 

other components in T1122H06, including: 

 

 HPE Shadowbase Audit Reader,  

 HPE Shadowbae Compare for SQL, 

 HPE NonStop Shadowbase Guardian replication, and  

 HPE NonStop Shadowbase OSS replication. 

 

You are advised to reference those other softdocs for the changes related 

to those specific components. 

 

http://www.gravic.com/
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Disclaimer 

 

We are distributing this communication in an effort to bring important information to the 

attention of users of the affected products. We recommend that all users determine the 

applicability of this information to their individual situations and take appropriate action. 

We do not represent or warrant that this information is necessarily accurate or complete 

for all user situations and, consequently, we will not be responsible for any damages 

resulting from the user’s use or disregard of the information provided. To the extent 

permitted by law, we disclaim all representations and warranties, whether express, 

implied, statutory, or otherwise, including the warranties of the merchantability, fitness 

for a particular purpose, title, and non-infringement. 
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Special Notes for Version 6.230 

1) The SEM help subsystem requires web browsers that support HTML 5. If you have 

issues displaying help, please upgrade to the latest version of your browser. Help is 

supported by Mozilla Firefox version 4 or later, Google Chrome version 9 or later, 

and Internet Explorer 9 or later. 

Changes in Release 6.230 

This section summarize the new features and problems fixed since the last General 

Availability release, Gravic version 6.100.  

New Features in Release 6.230 

1) The look and feel for SEM has been significantly updated for a more modern 

appearance. This includes minor usability enhancements as well as updated visual 

components. 

 

2) The traffic light icons, used to monitor the status of objects, have been updated to 

include non-color related visual indications of the status. See Traffic Light 

Enhancements, below. 

 

3) Support for Shadowbase Nonstop Queue Manager (QMGR) objects has been added 

to SEM. See Shadowbase NonStop Queue Manager (QMGR) Support, below for 

information related to monitoring the QMGR object through the traffic light icon. 

 

4) SEM now supports multiple ports for listeners as part of its configuration. This will 

allow a pool of listeners to be started and shared among multiple SEM users. See 

Multiple Port Configuration, below for more information. 

 

5) SEM now supports monitoring event totals for replication objects. See SEM now 

supports the input of multiple port numbers when connecting to a listener on the 

Open/Other and NonStop environments. To configure a listener object with multiple 

available ports in either environment refer to their respective documentation.  

 

Open the connect screen either by clicking on File > Connect… or by clicking on the 

connect button  located on the menu bar. This will open the following connect 

screen:  

 

The port input field can now accept multiple ports and test all of them for connectivity. 

The syntax for port input is as follows:  

- Comma separated list: <port1>, <port2>, <port3> 
- Port range: <min port>-<max port>  

- Combination: <min port>-<max port>, <port1>, <port2>, <min port>-
<max port>  
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The following list shows examples of various port inputs based on the given syntax:  

- 30300, 30310, 30315 

- 30300-30315  

- 30300-30315, 30327, 30330, 30330-30335  

 

For multiple port inputs, SEM will check every port number when attempting to connect 

to the environment and stop on the first successful option. Once connected, SEM will 

remember the port that successfully connected and will start the search with that port 

when re-connecting.  

6) Event Totals Monitoring, below for more information. 

 

7) SEM can be configured to use user authentication to allow email to be sent to external 

email addresses. Most email servers are configured to reject requests to forward email 

to external users without user authentication. See Email Authentication, below for 

more information on the email configuration changes. 

 

Problems Fixed in Release 6.230 

 

1) SEM had a memory leak that would eventually lead to its failure. This issue has been 

fixed. 

 

2) SEM’s help subsystem has been updated with information on the new dialogs and 

functionality. In addition, it has been changed to use an html based help framework, 

rather than the obsolete .chm help file. 

 

3) Status Email messages were using the internal color names (firebrick, green2) to 

indicate the status of the object. This has been corrected, SEM now uses the generic 

color names (red, yellow, green). 

 

4) SEM abended attempting to connect to a non-existent listener. This issue has been 

fixed. 

 

5) SEM abended removing a non-existent listener. This issue has been fixed. 

 

6) The status for the connected listener was not correctly displayed by SEM and did not 

match the status returned by the LIST STATUS command. 

 

7) SEM assumed server normal state was always ‘green’ even though normal state was 

supposed to be configurable. It allows configuration and correctly assumes the normal 

state for each server now. 
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New Features Description 

Traffic Light Enhancements 

SEM server status traffic icons have been upgraded to have a more pleasing 

look. The icons more accurately resemble their real-life counterparts and offer 

more color contrast to allow the user to quickly assess server status. In addition 

to improving aesthetic appearance, SEM traffic icons are now accessible for 

colorblind individuals. 

 

The projections on either side of the traffic light indicate the currently or most 

recently active color. The top left icon shows a traffic light that is currently off 

and shows that the most recently active color was green. The bottom left icon 

shows a traffic light that is currently on and shows that the active color is 

green. Below are examples of other color configurations:  

 

 

 

 

 

 

 

Shadowbase NonStop Queue Manager (QMGR) Support 

SEM supports the configuration and use of the Shadowbase Queue Manager.  

 

The image to the left shows the icon and associated data displayed in 

SEM for a configured QMGR. As with other objects, the name 

displays above, and the server type displays below.  

 

Upon right-click, the Queue Manager displays a list of options 

available:  

 

 

TOTALS: displays the total inserts + updates + deletes stats for the configured queue 

manager. The display shows various aspects of the I+U+D including the overall total, 

total since last update, and an average rate of change. 

 

Stop Blinking: stops the monitor from blinking.  
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Hide: hides the icon associated with the Queue Manager.  

 

Multiple Port Configuration 

SEM now supports the input of multiple port numbers when connecting to a listener on 

the Open/Other and NonStop environments. To configure a listener object with multiple 

available ports in either environment refer to their respective documentation.  

 

Open the connect screen either by clicking on File > Connect… or by clicking on the 

connect button  located on the menu bar. This will open the following connect 

screen:  

 

The port input field can now accept multiple ports and test all of them for connectivity. 

The syntax for port input is as follows:  

- Comma separated list: <port1>, <port2>, <port3> 
- Port range: <min port>-<max port>  

- Combination: <min port>-<max port>, <port1>, <port2>, <min port>-
<max port>  

 

 

 

 

 

 

The following list shows examples of various port inputs based on the given syntax:  

- 30300, 30310, 30315 

- 30300-30315  

- 30300-30315, 30327, 30330, 30330-30335  

 

For multiple port inputs, SEM will check every port number when attempting to connect 

to the environment and stop on the first successful option. Once connected, SEM will 

remember the port that successfully connected and will start the search with that port 

when re-connecting.  
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Event Totals Monitoring 

SEM supports monitoring for Insert+Update+Delete totals for objects that are able to 

complete such actions. To configure monitoring of IUD:  

 

1. Under the Options menu, select Monitor Preferences 

 

2. In the resulting window, select the Light Options tab 

 
3. Under the section titled Monitor Polling Interval specify the frequency at 

which to update the monitors’ stats. By default the monitors update once 

every 5 minutes.  

 

 

4. Under the UID Monitoring Interval section specify the frequency of the UID 

checks for each capable monitor. The rate is defined by number of monitor 

updates per UID check. 
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5. Move to the Blinking tab under the section titled Blinking Conditions. There 

you may specify whether the monitors should blink when a lack of inserts, 

updates, and deletes is detected. 

 

6. Under the Options menu, select Configure Email… 

 

7. In the resulting window, open the Event Messages tab 

 

8. Under the Send Message When section, you can select ‘UID stats are not 

updating in the configured intervals.’ This will alert recipients of monitors 

whose UID stats are not updating as expected. 
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Email Authentication 

SEM now supports the use of SMTP mail authentication and mail relay servers. Setup 

instructions and documentation for configuring SMTP authentication vary depending on 

the mail server. Consult the documentation for your mail server to determine the 

appropriate values for username, password, ip address, and port. 

 

To configure SEM to use a third party relay server, click on Options > Configure Email. 

In the resulting window, fill in the relevant host and port number specified by the third 

party. SEM SMTP mail runs on top of TLS– this will dictate which port number to use 

for the desired service. Next click on the check box labeled ‘Requires SMTP auth’ in 

order to enable username and password input. In the username field enter the e-mail 

address of the account with which you have configured and enabled e-mail relaying. In 

the password field enter the password associated with the e-mail. We do not store these 

credentials for our use. You can choose to save the credentials by clicking on the check 

box labeled ‘Remember me’ which will store your credentials locally and allow you to 

use them without re-entering them each time. These are encrypted and decrypted for 

security. To verify the settings are correct, click on the button labeled ‘Send Test Email.’ 

If the settings are correct, the addresses in the ‘To’ and ‘CC’ fields will receive an e-mail 

from the address specified in the ‘Username’ field.  

Installation Instructions 

 

SEM is provided with a standard Windows installer. Unzip the downloaded file, change 

directory to the SEM installation directory, and run setup.exe. The installer will take you 

through the remaining installation tasks. 

Known Problems Remaining 

1) The listener for Shadowbase Other Server environments will not properly connect if it 

is named using a one-character object name. 

 

 

*** End of Document *** 


